Wednesday, January 20, 2021

Huawei NE40 & CE12800 on EVE-NG

If  you ever wanted to simulate a Huawei NE40 router or Huawei 12800 series switches, you might heard of eNSP (enterprise Network Simulator).  Unfortunately Huawei stopped developing eNSP and is not sharing the program anymore. You might still found it on the internet of course but it makes your job harder if you ever wanted to simulate a multi-vendor environment with Huawei software.

On Eve-NG website, Huawei NE40 and Huawei 12800 is not listed under how-to's part. But if you dig in Huawei forums, you could find that it is possible.  

Huawei CE12800

On this forum page you could find each and every detail to make Huawei CE12800  image work on EVE-NG: 

https://forum.huawei.com/enterprise/en/run-ce12800-ne40e-in-eve-ng/thread/653457-861?page=4 

You need to register to find to see the links. 

I'm just sharing again the info on the forum page. I tested it and yes it works: 

  • Download the CE12800 images and configuration file, also the CE12800 icon. And extract the download image.
  • Upload the configuration(huaweice12800.yml) into the EVE-NG path: /opt/unetlab/html/templates/intel/ If you are using the AMD CPU, the accordingly path is /opt/unetlab/html/templates/amd/ 

  • Upload the ce icon file(ce.png) into the EVE-NG path: /opt/unetlab/html/images/icons/
  • Upload the CE12800 image into the EVE-NG path: /opt/unetlab/addons/qemu/ 

When adding new images to eve-ng, the trick is that the naming convention of the .yml file need to match with the folder name. Folder name might have version but after the right name.

  • Fix the permission using command: /opt/unetlab/wrappers/unl_wrapper -a fixpermissions

Huawei NE40

NE40 img is shared also on the forum page: https://forum.huawei.com/enterprise/en/run-ne40-ce12800-in-eve-ng/thread/672651-865 .Unfortunately these images are most probabily converted from eNSP images, so there is no newer version. VRP8R11 is the latest version. If you can manage to convert an standart image (.img to qcow2 in the right  way ?!) newer versions might work also. 

Here are the files (link is shared on Huawei forum page): https://mega.nz/file/sQEyTRbB#PnT37xH0tHXjeJWTd8xu9L1jdeiHkBnsGCzju3z3DmY

The instructions are same with Huawei12800, just be careful with naming the .yml file and img folder to be consistent with each other.



MISSING FEATURES 

I realized that there are some limitations with eNSP images, here are the ones i found: 
  • Subinterface only works if you configure static arp entries. 
  • Gig 0/0/0 always use same mac address. So if you use more than one router to a mngt network etc, use Ethernet instead of gig0/0/0 cause you cant  assign static mac to Gig0/0/0










3 comments:

ex-expert said...

If you use the command "arp broadcast enable" on the sub-interface, you do not need static ARP entries. I have no idea why this was default behaviour on some version of VRP, but it affects real routers as well......

Erçin TORUN said...

The problem i mentioned is not related with "arp broadcast enable". "arp broadcast enable" need to be entered if you configure subinterfaces with "encapsulation ..." dommand rather than "vlan type dot1q vid" command. there are two ways of configuring it.

Unknown said...

Thx! I connected two CE12800 nodes to each other, configured a static arp, as it was written above, but the nodes still do not ping, please send someone a working configuration.

SW1
=================================
interface Vlanif10
ip address 192.168.0.1 255.255.255.252
mac-address 3864-0111-1201
#
interface GE1/0/0
undo shutdown
port link-type hybrid
port hybrid tagged vlan 10
#
arp static 192.168.0.2 3864-0111-1202 vlan 10 interface GE1/0/0
================================

SW2

=================================
interface Vlanif10
ip address 192.168.0.2 255.255.255.252
mac-address 3864-0111-1202
#
interface GE1/0/0
undo shutdown
port link-type hybrid
port hybrid tagged vlan 10
#
arp static 192.168.0.1 3864-0111-1201 vlan 10 interface GE1/0/0
================================

Post a Comment

 

Internetworking Hints Copyright © 2011 -- Template created by O Pregador -- Powered by Blogger